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Chapter 1: Resources

Before you begin working with your software, take a few moments to read an overview of activation and the many 

resources available to you. You have access to instructional videos, plug-ins, templates, user communities, seminars, 

tutorials, RSS feeds, and much more.

Activation and registration

Help with installation

For help with installation issues, see the Installation Support Center at www.adobe.com/go/cs4install.

License activation

During the installation process, your Adobe software contacts Adobe to complete the license activation process. No 

personal data is transmitted. For more information on product activation, visit the Adobe website at 

www.adobe.com/go/activation.

A single-user retail license activation supports two computers. For example, you can install the product on a desktop 

computer at work and on a laptop computer at home. If you want to install the software on a third computer, first 

deactivate it on one of the other two computers. Choose Help > Deactivate.

Register

Register your product to receive complimentary installation support, notifications of updates, and other services.

❖ To register, follow the on-screen instructions in the Registration dialog box, which appears after you install the 

software. 

If you postpone registration, you can register at any time by choosing Help > Registration. 

Adobe Product Improvement Program

After you use your Adobe software a certain number of times, a dialog box may appear asking whether you want to 

participate in the Adobe Product Improvement Program.

If you choose to participate, data about your use of Adobe software is sent to Adobe. No personal information is 

recorded or sent. The Adobe Product Improvement Program only collects information about which features and tools 

you use and how often you use them.

You can opt in to or out of the program at any time:

• To participate, choose Help > Adobe Product Improvement Program and click Yes, Participate.

• To stop participating, choose Help > Adobe Product Improvement Program and click No, Thank You.

http://www.adobe.com/go/cs4install
http://www.adobe.com/go/activation
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ReadMe

A ReadMe file for your software is available online and on the installation disc. Open the file to read important 

information about topics such as the following:

• System requirements

• Installation (including uninstalling the software)

• Activation and registration

• Font installation

• Troubleshooting

• Customer support

• Legal notices

Help and support

Community Help

Community Help is an integrated environment on adobe.com that gives you access to community-generated content 

moderated by Adobe and industry experts. Comments and ratings from users help guide you to an answer. Search 

Community Help to find the best content on the web about Adobe products and technologies, including these 

resources:

• Videos, tutorials, tips and techniques, blogs, articles, and examples for designers and developers.

• Complete online Help, which is updated regularly and is more complete than the Help delivered with your product. 

If you are connected to the Internet when you access Help, you automatically see the complete online Help rather 

than the subset delivered with your product.

• All other content on Adobe.com, including knowledgebase articles, downloads and updates, Developer 

Connection, and more.

Use the help search field in your product’s user interface to access Community Help. For a video of Community Help, 

see www.adobe.com/go/lrvid4117_xp.

Other resources

Printed versions of the complete online Help are available for the cost of shipping and handling at 

www.adobe.com/go/store. Online Help also includes a link to the complete, updated PDF version of Help.

Visit the Adobe Support website at www.adobe.com/support to learn about free and paid technical support options.

Services, downloads, and extras

You can enhance your product by integrating a variety of services, plug-ins, and extensions in your product. You can 

also download samples and other assets to help you get your work done.

http://www.adobe.com/go/lrvid4117_xp
http://www.adobe.com/go/store
http://www.adobe.com/support
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Adobe creative online services

Adobe® Creative Suite® 4 includes new online features that bring the power of the web to your desktop. Use these 

features to connect with the community, collaborate, and get more from your Adobe tools. Powerful creative online 

services let you complete tasks ranging from color matching to data conferencing. The services seamlessly integrate 

with desktop applications so you can quickly enhance existing workflows. Some services offer full or partial 

functionality when you’re offline too.

Visit Adobe.com to learn more about available services. Some Creative Suite 4 applications include these initial 

offerings:

Kuler™ panel Quickly create, share, and explore color themes online. 

Adobe® ConnectNow Collaborate with dispersed working teams over the web, sharing voice, data, and multimedia.

Resource Central Instantly access tutorials, sample files, and extensions for Adobe digital video applications.

For information on managing your services, see the Adobe website at www.adobe.com/go/learn_creativeservices_en.

Adobe Exchange

Visit the Adobe Exchange at www.adobe.com/go/exchange to download samples as well as thousands of plug-ins and 

extensions from Adobe and third-party developers. The plug-ins and extensions can help you automate tasks, 

customize workflows, create specialized professional effects, and more.

Adobe downloads

Visit www.adobe.com/go/downloads to find free updates, tryouts, and other useful software. 

Adobe Labs

Adobe Labs at www.adobe.com/go/labs gives you the opportunity to experience and evaluate new and emerging 

technologies and products from Adobe. At Adobe Labs, you have access to resources such as these:

• Prerelease software and technologies

• Code samples and best practices to accelerate your learning

• Early versions of product and technical documentation

• Forums, wiki-based content, and other collaborative resources to help you interact with like-minded users.

Adobe Labs fosters a collaborative software development process. In this environment, customers quickly become 

productive with new products and technologies. Adobe Labs is also a forum for early feedback. The Adobe 

development teams use this feedback to create software that meets the needs and expectations of the community.

Adobe TV

Visit Adobe TV at http://tv.adobe.com to view instructional and inspirational videos.

Extras

The installation disc contains a variety of extras to help you make the most of your Adobe software. Some extras are 

installed on your computer during the setup process; others are located on the disc.

To view the extras installed during the setup process, navigate to the application folder on your computer.

• Windows®: [startup drive]\Program Files\Adobe\[Adobe application]

http://www.adobe.com/go/learn_creativeservices_en
http://www.adobe.com/go/exchange
http://www.adobe.com/go/downloads
http://www.adobe.com/go/labs
http://tv.adobe.com
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• Mac OS®: [startup drive]/Applications/[Adobe application]

To view the extras on the disc, navigate to the Goodies folder in your language folder on the disc. Example:

•  /English/Goodies/

What’s new

New features

The following features are new to Adobe® Media Encoder CS4 .

Batch encoding
Adobe Media Encoder  includes several batch encoding features that let you easily create a dedicated media encoding 

workstation. Using this workstation lets you encode video and audio assets—a computationally demanding process—

without interrupting your work with other computer applications.

Prioritize the encoding of assets You can specify the order in which media assets are encoded. You can also specify a 

delayed start time so that encoding begins at a time when other applications aren’t using the encoding workstation.

Export duplicate items with multiple formats and encoding settings You can add multiple instances of the same 

media asset, and apply different export formats and encoding settings to each asset for use with different applications 

and delivery methods. 

Watch folder You can configure Adobe Media Encoder  to look for video or audio files in certain folders called 

watched folders. When Adobe Media Encoder  finds a video or audio file located in a watched folder, it encodes the file 

using the specified encoding settings. Adobe Media Encoder then exports the encoded file to the Output folder created 

inside the watched folder. For more information, see “Create a watch folder” on page 25.

Encoding presets
Adobe Media Encoder  includes encoding presets appropriate for the different video formats that it can export. Each 

encoding preset is designed for particular delivery scenarios and applications. Selecting a preset activates the 

appropriate video and audio encoding options (for example, bit rate, frame rate, and aspect ratio). In most cases, one 

of the provided presets matches your output goals. However, you can also adjust the parameters of an existing preset 

and save it as a custom preset. You can share customized presets with others and reload them when needed.

After Effect compositions and Adobe Premiere Pro sequences
You can import After Effects compositions and Adobe Premiere Pro sequences like any other supported file type.

Cue point support for F4V and FLV
Cue points cause video playback to start other actions within the presentation. For example, you can create a SWF 

application that has video playing in one area of the screen while text and graphics appear in another area. A cue point 

placed in the video triggers an update to the text and graphics, letting them remain relevant to the content of the video.



5

Chapter 2: Video and audio basics

About video and audio encoding

Recording video and audio to a digital format involves balancing quality with file size and bitrate. Most formats use 

compression to reduce file size and bitrate by selectively reducing quality. Compression is essential for reducing the 

size of movies so that they can be stored, transmitted, and played back effectively. Without compression, a single frame 

of standard-definition video uses nearly 1 MB (megabyte) of storage. At the NTSC frame rate of approximately 30 

frames per second, uncompressed video plays at nearly 30 MB per second, and 35 seconds of footage takes up about 1 

GB of storage. By comparison, an NTSC file compressed in DV format fits 5 minutes of footage into 1 GB of storage 

at a bitrate of about 3.6 MB per second. To compress video for distribution at the highest possible quality, select the 

smallest compression ratio that delivers video within the file size and bitrate constraints of your target delivery media 

and playback devices.

When exporting a movie file for playback on a specific type of device at a certain bandwidth, you choose a 

compressor/decompressor (also known as an encoder/decoder, or codec), to compress the information and generate a 

file readable by that type of device at that bandwidth.

A wide range of codecs is available; no single codec is best for all situations. For example, the best codec for 

compressing cartoon animation is generally not efficient for compressing live-action video. When compressing a 

movie file, you can fine-tune it for the best-quality playback on a computer, a mobile device, the web, or a DVD player. 

Depending on which encoder you use, you may be able to reduce the size of compressed files by removing artifacts that 

interfere with compression, such as random camera motion and excessive film grain.

If you are new to digital video or want to learn more about digital video and encoding high-quality video content, this 

information can help you understand the trade-offs related to encoding video for different applications and viewing 

environments.

Frame rate

Video is a sequence of images that appear on the screen in rapid succession, giving the illusion of motion. The number 

of frames that appear every second is known as the frame rate, and it is measured in frames per second (fps). The higher 

the frame rate, the more frames per second are used to display the sequence of images, resulting in smoother motion. 

The trade-off for higher quality, however, is that higher frame rates require a larger amount of data to display the video, 

which uses more bandwidth.

When working with digitally compressed video, the higher the frame rate, the larger the file size. To reduce the file size 

lower either the frame rate or the bitrate. If you lower the bitrate and leave the frame rate unchanged, the image quality 

is reduced. If you lower the frame rate and leave the bitrate unchanged, the video motion may look less smooth than 

desired.

Because video looks much better at native frame rates (the frame rate at which the video was originally filmed), Adobe 

recommends leaving the frame rate high if your delivery channels and playback platforms allow it. For full-motion 

NTSC (the standard defined by the National Television System Committee in the U.S.), use 29.97 fps; for PAL (Phase 

Alternating Line, the dominant television standard in Europe), use 25 fps. If you lower the frame rate (which can 

significantly reduce the video data that must be encoded), Adobe® Media Encoder CS4  drops frames at a linear rate to 

achieve the new fps rate. However, if you must reduce the frame rate, the best results come from dividing evenly. For 

example, if your source has a frame rate of 24 fps, then reduce the frame rate to 12 fps, 8 fps, 6 fps, 4 fps, 3 fps, or 2 fps. 

If the source frame rate is 30 fps, in most cases you can adjust the frame rate to 15 fps, 10 fps, 6 fps, and so on.
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Note: If a video clip is longer than 10 minutes, the audio will drift noticeably out of sync if you do not adhere to the 29.97 

fps rate or an accurate even division for lower frame rates (such as 14.98 fps, which is half of 29.97).

If your video clip is encoded with a higher bitrate, a lower frame rate can improve playback on lower-end computers. 

For example, if you are compressing a talking-head video clip with little motion, cutting the frame rate in half could 

save only 20% of the bitrate. However, if you are compressing high-motion video, reducing the frame rate has a much 

greater effect on the bitrate.

Bitrate

The bitrate (also referred to as the data rate) affects the quality of a video clip and the audience that can download the 

file given their bandwidth constraints.

When you deliver video using the Internet, produce files using lower bitrates. Users with fast Internet connections can 

view the files with little or no delay, but dial-up users must wait for files to download. If you anticipate an audience of 

dial-up users, make short video clips to keep the download times within acceptable limits.

Key frames

Key frames are complete video frames (or images) that are inserted at consistent intervals in a video clip. The frames 

between the key frames contain information on movement and scene changes that occurs between key frames. For 

example, if a video depicts a person walking past a doorway, the key frames contain the complete image of the person 

and the door in the background, and the interval frames contain information describing the person’s movement as 

they walk in front of the door.

By default, Adobe Media Encoder  automatically determines the key frame interval to use based on the frame rate of 

the video clip. The key frame interval value tells the encoder how often to re-evaluate the video image and record a full 

frame, or key frame, into a file. In Adobe Media Encoder , this setting is the key frame interval value, which represents 

the number of frames between key frames. Adobe Media Encoder  approximates frames that reside between key 

frames by estimating the full value of all pixels on the screen by comparing multiple frames and eliminating redundant 

information.

In general, the default key frame interval value provides a reasonable level of control when seeking within a video clip. 

If you select a custom key frame placement value, be aware that the smaller the key frame interval, the larger the file size.

If your footage has a lot of scene changes or rapidly moving motion or animation, then the overall image quality may 

benefit from a lower key frame interval. In general, a higher key frame interval produces better image quality because 

data is not wasted describing the areas of an image that remain unchanged from frame to frame.

Aspect ratios (frame size)

As with the frame rate, the aspect ratio (or frame size) for your file is important for producing high-quality video. At 

a specific bitrate (connection speed), increasing the frame size results in decreased video quality. When you select the 

frame size for your document, consider the frame rate, the aspect ratio of the source video clip, and your personal 

preferences to create a successful video presentation. Standard display resolutions on the Internet include 640 x 480, 

512 x 384, 320 x 240, and 160 x 120 pixels.

The most common aspect ratio is 4:3 (standard television). Increasingly, 16:9 and 2:1 (wide screen) aspect ratios are 

becoming more commonplace as well. Typically, you should encode the video using the same aspect ratio at which it 

was originally captured. Altering the aspect ratio of a video clip can result in black bars (or masks) being placed on the 

sides or top and bottom sides of the image. The black bars are necessary when video not originally designed for 

widescreen viewing is shown on a widescreen display, or a narrower widescreen image is displayed within a wider 
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aspect ratio. The original video is shrunk and placed in the middle of the widescreen frame. An exception to this 

practice is when encoding digital video (DV) formats, whose aspect ratio is slightly different than the 4:3 aspect ratio 

because DV uses rectangular pixels. When encoding video content captured with a digital video camera, manually 

specify the frame size of the DV format you are using to preserve the aspect ratio of the video, or select an appropriate 

preset (NTSC or PAL, for example).

The following list of standard frame sizes can be used as a guideline. You can experiment to find the best setting for 

your project.

Frame sizes for 4:3 aspect ratio video:

• Modem (56k): 160 x 120

• DSL: 320 x 240

• Cable: 512 x 384

• Cable/corporate LAN: 640 x 480

Frame sizes for 16:9 aspect ratio video:

• Modem (56k): 192 x 108

• DSL: 384 x 216

• Cable: 448 x 252

• Cable/corporate LAN: 704 x 396

Video with non-square pixels

Most static computer graphics use square pixels, which have a width-to-height ratio of 1:1. When working with digital 

video, pixels often have a different width-to height ratio and are referred to as rectangular pixels. The reason for this 

behavior is to allow analog video (for example, broadcast television) and digital video (for example, DVD video) to 

coexist. When encoding video formats with non-square pixels (also known as anamorphic video), resample the video 

image to the correct Display Aspect Ratio (DAR).

For example, standard NTSC digital video (DV), has a frame size of 720 x 480 pixels, and it’s displayed at an aspect 

ratio of 4:3. This means that each pixel is rectangular, with a pixel aspect ratio (PAR) of 10:11 (a tall, narrow pixel). 

Both MPEG 1 and 2 video are also produced in various sizes (720 x 480 or 480 x 480 are common) even though they 

are typically displayed with either a 4:3 or 16:9 (wide screen) aspect ratio.

To calculate the image frame size to use when encoding video using non-square pixels, first decide which dimension—

width or height—is the preferred master dimension, and then compute the other dimension as follows:

If height is the master dimension, calculate the width using the following formula:

For example, if your video uses an aspect ratio of 4:3 the equation would appear as: 

If width is the master dimension, calculate the height using the following formula:

width = height x 
aspect ratio width

aspect ratio height

width = height x 
3

4

height = width x 
aspect ratio height

aspect ratio width
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For example, if your video uses an aspect ratio of 4:3 the equation would appear as:

As an example, if you are encoding a video whose frame size is 720 x 480 pixels, and you want to encode it with a 4:3 

aspect ratio, first determine the width at which to encode the video frame in pixels:

The result is a video image height of 640 pixels.

Thus, you must encode the 720 x 480 image to 640 x 480, a standard 4:3 aspect ratio.

See also 

“Custom encoding settings” on page 32

Interlaced versus noninterlaced video

Adobe Media Encoder  deinterlaces video before encoding whenever you choose to encode an interlaced source to a 

noninterlaced output.

Most broadcast video is interlaced, though emerging high-definition television standards have interlaced and 

noninterlaced variants. Interlaced video consists of two fields that make up each video frame. Each field contains half 

the number of horizontal lines in the frame; the upper field (or Field 1) contains all of the odd-numbered lines, and 

the lower field (or Field 2) contains all of the even-numbered lines. An interlaced video monitor (such as a television) 

displays each frame by first drawing all of the lines in one field and then drawing all of the lines in the other field. Field 

order specifies which field is drawn first. In NTSC video, new fields are drawn to the screen approximately 60 times 

per second, which corresponds to a frame rate of approximately 30 frames per second.

Noninterlaced video frames are not separated into fields. A progressive-scan monitor displays a noninterlaced video 

frame by drawing all of the horizontal lines, from top to bottom, in one pass. Because of this, both fields that make up 

a video frame are shown simultaneously. Thus, a computer monitor displays video at 30 fps, and most video displayed 

on computer monitors is noninterlaced.

Compression tips

When you compress video, consider these recommendations:

Work with video in the native format of your project until your final output If you convert a precompressed digital 

video format into another format such as FLV or F4V, the previous encoder can introduce video noise. The first 

compressor already applied its encoding algorithm to the video, reducing its quality, frame size, and rate. That 

compression may have also introduced digital artifacts or noise. This additional noise affects the final encoding 

process, and a higher bitrate may be required to encode a good-quality file. Use raw footage or the least compressed 

footage that is available to you.

Make your video as short as possible Trim the beginning and end of your video, and edit your video to remove any 

unnecessary content.

height = width x 
4

3

640 = 480 x 
4

3
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Adjust your compression settings If you compress footage and it looks great, try changing your settings to reduce the 

file size. Test your footage, and modify it until you find the best setting possible for the video you are compressing. All 

video has varying attributes that affect compression and file size; each video needs its own setting for the best results.

Limit effects and rapid movement  Limit movement if you are concerned about file size. Any movement, particularly 

with many colors, increases file size. Shaky camera work and zooms are particularly bad in this regard. Some effects 

increase file size because of the information they add to the video. On the other hand, some effects, such as blurs, can 

be used to decrease the number of bits in a compressed file.

Choose appropriate dimensions  If your target audience has a slow Internet connection (such as phone modems), 

make the dimensions of your video smaller, such as 160x120 pixels. If your audience has fast connections, you can 

make your dimensions larger (for example, 320x240 pixels).

Select an appropriate frame rate Frame rate indicates frames per second (fps). If you have a higher bitrate clip, a lower 

frame rate can improve playback through limited bandwidth. For example, if you are compressing a clip with little 

motion, cutting the frame rate in half probably saves you only 20% of the bitrate. However, if you are compressing 

high-motion video, reducing the frame rate has a much greater effect on the data rate.

Because video looks much better at native frame rates, leave the frame rate high if your delivery channels and playback 

platforms allow. For web delivery, get this information from your hosting service. For mobile devices, use the device-

specific encoding presets, and the device emulator available through Adobe Media Encoder . If you must reduce the 

frame rate, the best results come from dividing the frame rate by whole numbers.

Note: When creating video for Flash, if you are creating a SWF file with embedded video, the frame rate of the video clip 

and the SWF file must be the same. If you use different frame rates for the SWF file and the embedded video clip, playback 

is inconsistent.

Choose an appropriate number of key frames Each key frame is a frame that draws when the video is compressed, so 

the more frequent your key frames are the better quality the footage is. More key frames also mean a larger file size. If 

you choose 30, a video key frame draws every 30 frames. If you choose 15, the quality is higher because a key frame 

draws ever 15 frames and the pixels in your footage are more accurate to the original.

Reduce noise  Noise (scattered pixels in your footage) increases file size. Reduce noise using your video editor, to 

reduce the video file size. Using more solid colors in your video reduces its file size. You can use the Gaussian blur filter 

to help reduce noise. 

Compression tips for audio files

The same considerations exist for audio production as for video production. To achieve good audio compression, you 

must begin an audio file that is free of distortion and audible artifacts introduced from the source recording. If you are 

encoding material from a CD, try to record the file using direct digital transfer rather than the analog input of a sound 

card. The sound card introduces an unnecessary digital-to-analog and analog-to-digital conversion that can create 

noise in your transferred audio. Direct digital transfer tools are available for both Windows and Macintosh platforms. 

If you must record from an analog source, use the highest quality sound card available.

Note: If your source audio file is monaural (mono), it is recommended that you encode in mono for use with Flash. If you 

are encoding with Adobe Media Encoder , and using an encoding preset, be sure to check if the preset encodes in stereo or 

mono, and select mono if necessary.
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Video formats

FLV and F4V video formats for Flash

By default, Adobe Media Encoder  encodes video for use with Flash using the F4V video format using the H.264 video 

codec for use with Flash Player 9.0.r115 and later, and the FLV format using either the On2 VP6 codec for use with 

Flash Player 8, and the Sorenson Spark codec for use with Flash Player 7. To understand how Flash achieves high-

quality video with low bandwidth requirements, you must understand video compression. 

There are two types of compression that can be applied to digital media: spatial and temporal. Spatial compression is 

applied to a single frame of data, independent of any surrounding frames. Spatial compression can be lossless (in which 

no data is discarded from the image) or lossy (in which data is selectively discarded). A spatially compressed frame is 

often called an intraframe.

Temporal compression identifies the differences between frames and stores only those differences, so that frames are 

described based on their difference from the preceding frame. Unchanged areas are repeated from the previous frames. 

A temporally compressed frame is often called an interframe.

H.264, On2 VP6, and Sorenson Spark are interframe codecs. Although many other codecs use intraframe compression 

(for example, JPEG is an intraframe codec), the efficient interframe compression of the H.264, On2 VP6, and Sorenson 

Spark codecs, among other features, distinguishes them from other compression technologies because these codecs 

require a much lower bitrate (also known as the bit rate) to produce high-quality video.

It’s important to note that interframe codecs also use intraframes. Intraframes are used as the reference frames (key 

frames) for the interframes. Both the On2 VP6 and Sorenson Spark codecs always begin with a key frame. Each key 

frame becomes the main reference frame for the following interframes. Whenever the next frame is significantly 

different from the previous frame, the codec compresses a new key frame.

An important dependency of the key frame distance is that it affects the ability of Flash Player to seek (fast-forward or 

rewind) through an FLV or F4V file. Flash Player can only advance from key frame to key frame, so if you want to skip 

to different places and pause the frames, use a lower key frame distance value. If you want to advance to every frame 

in an FLV or F4V file, use a key frame distance value of 1. When you reduce the key frame distance value, raise the 

bitrate for the video file to maintain comparable image quality.

H.264, On2 VP6, and Sorenson Spark video codecs

When encoding video using Adobe Media Encoder , you can choose from three different video codecs with which to 

encode your video content for use with Flash Player: 

H.264 Support for H.264 video was incorporated into Flash Player beginning with version 9.0.r115. F4V video is a 

container format for the H.264 video codec, also referred to as MPEG-4 AVC (Advanced Video Encoding). The H.264 

video codec provides higher quality video at lower bitrates than the Sorenson Spark and On2 VP6 video codecs used 

by earlier version of Flash Player, however, it is more computationally demanding than either of these codecs. 

In addition to the F4V container format, Flash Player 9.0.115.0 and later versions support files derived from the 

standard MPEG-4 container format. These files include MP4, M4A, MOV, MP4V, 3GP, and 3G2, if they contain 

H.264 video or HE-AAC v2 encoded audio, or both.

Note:  If you need to use video with alpha channel support for compositing, use the On2 VP6 video codec; F4V does not 

support alpha video channels.

On2 VP6 The On2 VP6 codec is the preferred video codec to use when creating FLV files you intend to use with Flash 

Player 8 and higher. The On2 VP6 codec provides:

• Higher quality video when compared to the Sorenson Spark codec encoded at the same bitrate
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• Support for the use of an 8-bit alpha channel to composite video

To support better quality video at the same bitrate, the On2 VP6 codec is noticeably slower to encode and requires 

more processor power on the client computer to decode and play back. For this reason, carefully consider the lowest 

common denominator of computer you intend your viewing audience to use when accessing your FLV video 

content.

Sorenson Spark Introduced in Flash Player 6, the Sorenson Spark video codec can be used to publish Flash documents 

requiring backwards compatibility to Flash Player 6 and 7. If you anticipate a large user base that uses older computers, 

use FLV files encoded with the Sorenson Spark codec, as it is much less computationally demanding to play back than 

either On2 VP6 or F4V video.

F4V and FLV encoding presets

When exporting with Adobe® Media Encoder CS4 , choosing an FLV or F4V format automatically makes available a 

list of associated presets designed for particular delivery scenarios. Selecting a preset, in turn, activates the appropriate 

options in the various settings tabs (Video, Audio, and so on). In most cases, one of the provided presets matches your 

output goals. However, you can also adjust the parameters of an existing preset and save it as a custom preset. The 

following table lists the encoding settings used when you select from the FLV | F4V presets. The table lists information 

on the dimensions of the video produced by a given preset, and the video codec used with the stated Flash Player 

version.

Format Preset label Dimensions

F4V with the H.264 video codec (Flash Player 

9.0.r115 and higher)

Same As Source Maintains dimensions and frame rate of 

source

1080 pixels; Source, Half Size 960 x 540 pixels

1080 pixels; Source, Quarter Size 480 x 270 pixels

720 pixels Source, Half Size 640 x 360 pixels

720 pixels Source, Quarter Size 320 x 180 pixels

HD 1080 pixels 1920 x 1080 pixels

HD 720 pixels 1280 x 720 pixels

Web Large, NTSC Source Maintains proper aspect ratio of NTSC video

Web Large, PAL Source Maintains proper aspect ratio of PAL video

Web Large, Widescreen Source Maintains proper aspect ratio of widescreen 

video

Web Medium 360 x 264 pixels

Web Medium, Widescreen Source Maintains proper aspect ratio of widescreen 

video

Web Small 328 x 240 pixels

FLV with On2 video codec (Flash 8 and 

higher)

Same As Source Maintains dimensions and frame rate of 

source 

Web Large, NTSC Source Maintains aspect ratio of NTSC video

Web Large, PAL Source Maintains aspect ratio of PAL video

Web Large, Widescreen Source Maintains proper aspect ratio of widescreen 

video 
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Exporting for Adobe Media Player

Adobe Media Player is the preeminent player of FLV files, either streaming from a server or played back from a local 

hard disk. You can export FLV files for playback in the Adobe Media Player. Select FLV | F4V from the Format menu 

in the Export Settings dialog box. Then, select specific settings to meet the requirements of the FLV host or your target 

audience.

For information on selecting an FLV codec in the Export Settings dialog box, see About the On2 VP6 and Sorenson 

Spark Video Codecs on the Capturing And Encoding Video page on the Developer Center website.

For information about choosing the best video, audio, encoding, and bit rate settings for your target audience, see the 

Flash video (FLV) bitrate calculator on the Developer Center website.

For more information about exporting video for the Adobe Media Player, see www.adobe.com/go/lrvid4116_xp.

See also 

www.adobe.com/go/lrvid4116_xp

www.adobe.com/go/lrvid4093_xp

www.adobe.com/go/lrvid4097_xp

MPEG

MPEG is the name of a family of file formats specified by the ISO/IEC Moving Picture Experts Group. MPEG formats 

include several compression methods. It requires significant processing power and time to generate these key frame-

based file formats from other video formats.

MPEG-1 Typically used for the Internet and CD-ROM, providing picture quality comparable with VHS quality at 

quarter-screen frame size.

MPEG-2 Delivers higher quality video than MPEG-1. A specific form of MPEG2 was chosen as the standard for 

compressing video for DVD video. This is called DVD-compliant MPEG-2. MPEG-2 compression is also used in 

HDV, and supported in the HD-DVD, and Blu-ray formats.

MPEG-4  Includes many of the features of MPEG-1 and MPEG-2, and adds support for interactivity. It offers better 

compression and reduces file size while maintaining the same perceptual quality level as MPEG-2. MPEG-4 part 10 

(H.264, AVC) is the supported by the Blu-ray and HD-DVD formats. 

Adobe Media Encoder  offers a number of MPEG presets to optimize the output quality for various project types. If 

you’re experienced with MPEG encoding, you can further fine-tune projects for specific playback situations by 

customizing the presets in the Export Settings dialog box.

Web Medium 360 x 264 pixels

Web Medium, Widescreen Source Maintains proper aspect ratio of widescreen 

video

Web Modem 164 x 120 pixels

Web Small 328 x 240 pixels

FLV with Sorenson Spark video codec (Flash 7 

and higher)

Same As Source Maintains dimensions and frame rate of 

source with Sorenson Spark codec

Format Preset label Dimensions

http://www.adobe.com/devnet/flash/articles/video_guide_03.html
http://www.adobe.com/devnet/flash/apps/flv_bitrate_calculator/index.html
http://www.adobe.com/go/lrvid4116_xp
http://www.adobe.com/go/lrvid4116_xp
http://www.adobe.com/go/lrvid4093_xp
http://www.adobe.com/go/lrvid4097_xp
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High-definition (HD) video

High-definition (HD) video refers to any video format with pixel dimensions greater than those of standard-definition 

(SD) video formats. Typically, standard-definition refers to digital formats with pixel dimensions close to those of 

analog TV standards, such as NTSC and PAL (around 480 or 576 vertical lines, respectively). The most common HD 

formats have pixel dimensions of 1280x720 or 1920x1080, with a widescreen aspect ratio of 16:9.

HD video formats include interlaced and noninterlaced varieties. Typically, the highest-resolution formats are 

interlaced at the higher frame rates, because noninterlaced video at these pixel dimensions would require a 

prohibitively high data rate. 

You can reap benefits from shooting and editing in high-definition formats even if you output to standard definition. 

For example, the quality of high-definition clips remains high when you zoom into them or pan across them in the 

context of standard-definition projects.

HD video formats are designated by their vertical pixel dimensions, scan mode, and frame or field rate (depending on 

the scan mode). For example, 1080i60 denotes interlaced scanning of 60 interlaced 1920x1080 fields per second, 

whereas 720p30 denotes progressive scanning of 30 noninterlaced 1280x720 frames per second. In both cases, the 

frame rate is approximately 30 frames per second.

Adobe digital video applications include presets that are designed for working with various high-definition formats. 

Some of the most common high-definition video formats you may encounter include the following:

High-definition video recording formats
AVCHD (Advanced Video Codec High Definition) High-definition format based on an MPEG-4 AVC video codec for 

file-based (tapeless) cameras. AVCHD was introduced by Sony and Panasonic. For more information about AVCHD, 

see the article AVCHD on the Wikipedia website.

DVCPRO HD or DVCPRO100 Panasonic’s high-definition variant of its DVCPRO format, which also includes 

DVCPRO25 and DVCPRO50. Whereas DVCPRO25 and DVCPRO50 support data rates of 25 Mbits/s (megabits per 

second) and 50 Mbit/s, respectively, DVCPRO HD supports a data rate of 100 Mbit/s, from which it gets its other 

name, DVCPRO100. DVCPRO HD footage can be captured to Panasonic P2 media. For more information about 

DVCPRO HD, see the DVCPRO section of the article DV on the Wikipedia website.

HDCAM Sony’s high-definition version of its Digital Betacam format. A variant called HDCAM SR uses a tape with a 

higher particle density to record video with greater color sampling and at higher bit rates. However, HDCAM SR is 

supported by decks only, and not camcorders. For more information about HDCAM and HDCAM SR, see the article 

HDCAM on the Wikipedia website.

XDCAM HD and XDCAM EX  High-definition formats developed by Sony for file-based (tapeless) cameras. For more 

information about XDCAM HD and XDCAM EX, see the article XDCAM on the Wikipedia website.

HDV Developed jointly by several companies, HDV employs a form of MPEG-2 compression to enable high-

definition video to be encoded onto standard miniDV cassette media. For more information about HDV, see the 

article HDV on the Wikipedia website.

High-definition codecs
H.264 An MPEG-4-based codec that supports encoding in high definition for Blu-ray Disc media, and the FLV |F4V 

formats. For more information about H.264, see the article H.264/MPEG-4 AVC on the Wikipedia website.

V210 An uncompressed codec that supports encoding in high definition at 10-bit 4:2:2 in component YCbCr. 

Supported by the Uncompressed Microsoft AVI format.

UYVY A codec that supports encoding in high definition in YUV 4:2:2. Supported by the Uncompressed Microsoft 

AVI format.

http://en.wikipedia.org/wiki/AVCHD
http://en.wikipedia.org/wiki/DV#DVCPRO
http://en.wikipedia.org/wiki/HDCAM
http://en.wikipedia.org/wiki/XDCAM
http://en.wikipedia.org/wiki/HDV
http://en.wikipedia.org/wiki/H.264
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MPEG2 A codec that supports encoding in high-definition for Blu-ray Disc. File extensions: .m2v, .wav (audio only).

VC-1 A codec that supports encoding in high-definition for Windows Media Video. For more information about VC-

1, see the article VC-1 on the Wikipedia website.

Windows Media Video 9 A codec that supports encoding in high-definition for Windows Media Video. For more 

information about Windows Media 9, see the article Windows Media Video on the Wikipedia website.

See also 

HDV Vs HD: A Primer

Uncompressed Vs. Compressed by Bob Turner

Video Codec And Pixel Format Definitions

Creating motion-picture film

If you intend to display your finished project on motion picture film, plan your workflow carefully. You can employ a 

matchback process, in which you shoot on film, transfer to video, and then conform the film negative to your video 

edits. On the other hand, you can shoot and edit video, and then transfer the finished project to film. Ideally, you would 

shoot a high-definition format, and perhaps shoot at 24 fps to match theatrical film frame rate. In either case, consider 

the important ways film and video formats differ—such as in their image resolutions, aspect ratios, and frame rates. 

Develop a plan to reconcile those differences.

Choose carefully the acquisition format that best suits your needs, both for production and post-production. Post-

production tools sometimes require you to acquire your footage in specific formats, or to convert your footage to them. 

When exporting from post-production software, you can determine the settings appropriate to the film stock you’ll 

use. Alternatively, you can decide how to best translate your editing decisions to film. If you choose to transfer video 

to film, you can employ a facility that can make the transfer. The facility can use a film recorder, a device that prints 

video frames to motion picture film frames. To determine the best course, consult the production and post-production 

facilities before you begin.

http://en.wikipedia.org/wiki/VC-1
http://en.wikipedia.org/wiki/Windows_Media_9
http://library.creativecow.net/articles/kolb_tim/hdv_vs_hd_primer.php
http://digitalcontentproducer.com/hdhdv/depth/video_uncompressed_vs_compressed/
http://www.fourcc.org/
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Chapter 3: Encoding media

About Adobe Media Encoder

Adobe® Media Encoder CS4  is a video and audio encoding application that lets you encode audio and video files into 

a variety of distribution formats for different applications and audiences. These video and audio formats are more-

compressed formats such as:

• Adobe® FLV | F4V for use with Adobe Flash Player

• H.264 used for video iPod, 3GPP mobile phones, PSP devices

• MPEG-1 used in CD-ROM authoring (Windows only)

• MPEG-2 used in DVD authoring (Windows only)

• Apple® QuickTime®

• Windows Media (Windows only)

Adobe Media Encoder  accommodates the numerous settings these formats offer, and also includes preset settings 

designed to export files compatible with particular delivery media. Using Adobe Media Encoder , you can export video 

in formats suitable for devices ranging from DVD players to websitse to mobile phones to portable media players and 

standard- and high-definition TV sets.

Using Adobe Media Encoder  on a computer dedicated for video encoding lets you batch-process multiple video and 

audio clips; in environments where video is a significant form of content, batch-processing expedites your workflow. 

You can add, reorder, and change the encoding settings of files in the batch-processing queue while 

Adobe Media Encoder  is encoding video files.

Adobe Media Encoder  provides different video export formats depending on the Adobe applications it is installed 

with. When installed with only Adobe Flash CS4, Adobe Media Encoder  provides export formats for Adobe FLV | 

F4V and H.264 video. When installed with Adobe® Premiere Pro CS4 and Adobe® After Effects, additional export 

formats are available.

See also 

“Video formats” on page 10

File formats supported for import

 Some filename extensions—such as MOV, AVI, MXF, FLV, and F4V—denote container file formats rather than 

denoting a specific audio, video, or image data format. Container files can contain data encoded using various 

compression and encoding schemes. Adobe Media Encoder  can import these container files, but the ability to import 

the data that they contain is dependent on which codecs (specifically, decoders) are installed.

By installing additional codecs, you can extend the ability of Adobe Media Encoder  to import additional file types. 

Many codecs must be installed into the operating system (Windows or Mac OS) and work as a component inside the 

QuickTime or Video for Windows formats. Contact the manufacturer of your hardware or software for more 

information about codecs that work with the files that your specific devices or applications create.
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Note: The free trial version of Adobe Media Encoder  software, and trial versions of software applications with which it 

is installed, does not include some features that depend upon software licensed from parties other than Adobe. For 

example, some codecs for encoding MPEG formats are available only with the full version of Adobe Media Encoder 

software. You cannot encode the following file formats using the trail version: MPEG-1, MPEG-2, and MPEG-4; F4V; 

M4A; MP4; and 3G2. To import these file formats, you must register the software.

Supported video and animation file formats
• 3G2

• Animated GIF (GIF)

• DLX (Sony VDU File Format Importer, Windows only)

• DV (in MOV or AVI container, or as a containerless DV stream)

• FLV, F4V

Note: FLV files contain video and audio data encoded using the On2 VP6 or Sorenson Spark video codec with the MP3 

audio codec, whereas F4V files contain video encoded using the H.264 codec and audio data encoded using the AAC 

codec.

• M2T (Sony HDV)

• MOV (QuickTime; in Windows, requires QuickTime player)

• MP4 (XDCAM EX)

• MPEG-1, MPEG-2, and MPEG-4 formats (MPEG, MPE, MPG, M2V, MPA, MP2, M2A, MPV, M2P, M2T, AC3, 

MP4, M4V, M4A)

Note: Some MPEG data formats are stored in container formats with filename extensions that are not recognized by 

Adobe Media Encoder ; examples include .vob and .mod. In some cases, you can import these files into 

Adobe Media Encoder  after changing the filename extension to one of the recognized filename extensions. Because of 

variations in implementation in these container formats, compatibility is not guaranteed.

• MTS (AVCHD)

• Media eXchange Format (MXF)

Note: MXF is a container format. Adobe Media Encoder can only import some kinds of data contained within MXF 

files. Adobe Media Encoder can import the Op-Atom variety used by Panasonic DV, DVCPRO, DVCPRO50, and 

DVCPRO HD video cameras to record to Panasonic P2 media. Adobe Media Encoder can also import XDCAM HD 

files in MXF format.

• Netshow (ASF, Windows only)

• QuickTime (MOV; 16 bpc, requires QuickTime)

• Video for Windows (AVI, WAV; requires QuickTime on Mac OS)

Note: Adobe Media Encoder  cannot import DivX® video files, or AVI files encoded with DivX.

• WMV (WMV, WMA, ASF; Windows only)

Supported audio file formats
• Adobe Sound Document (ASND; multi-track files imported as merged single track)

• Advanced Audio Coding (AAC, M4A)

• Audio Interchange File Format (AIF, AIFF)

• AVI (Audio Video Interleaved)
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• WAV (Audio WAVeform)

• MP3 (MP3, MPEG, MPG, MPA, MPE)

• MOV (QuickTime; in Windows, requires QuickTime player)

• Windows Media Audio (WMA, Windows only)

• Video for Windows (AVI, WAV; requires QuickTime on Mac OS)

Supported still-image and sequence file formats
Adobe Media Encoder  supports 8-bit per-channel (4 bytes per pixel) and 16-bit per-channel (8 bytes per pixel) still-

image files. It converts images with lower bit-depths to 8-bits per channel and images with higher bit-depths to 16-bits 

per channel on import. High bit-depth files are supported at one single-precision float per channel (16-bytes per pixel).

• Adobe Photoshop and Photoshop sequence (PSD)

• Bitmap and Bitmap sequence (BMP, DIB, RLE)

• GIF

• Icon File (ICO) (Windows only)

• JPEG and JPEG sequence (JPE, JPG, JFIF)

• PICT and PICT sequence (PIC, PCT)

• Portable Network Graphics (PNG)

• Targa and Targa sequence (TGA, ICB, VDA, VST)

• TIFF and TIFF sequence (TIF)

Note: You can import layered Illustrator and Photoshop files as sequences.

Supported video project file formats
• Adobe Premiere Pro (PRPROJ)

• After Effects Project (AEP)

See also 

“Video formats” on page 10

Encode media

Adobe Media Encoder workspace

The Adobe Media Encoder  workspace includes tools and panels that help you easily add media assets to the encoding 

queue, and select a suitable encoding format for use with the intended application and user audience. You can also edit 

video using crop and trim controls, add  points to trigger events at specified points during playback, and adjust the 

export settings of any format for a specific application or audience. 

Export Queue window

The Export Queue window (the main Adobe Media Encoder  application window) lets you add media assets to the 

encoding queue, select encoding formats and encoding settings, manage the progress of the export queue, preview the 

currently encoding video, and monitor the elapsed and remaining encoding times of media assets using a progress bar.
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Export Queue window.
A. Export queue list  B. Progress bar  C. Queue controls  D. Video preview window   

Export Settings viewing area

The Export Settings dialog box includes a large viewing area where you can toggle between Source and Output tabs. 

The Source tab includes an image area, and an interactive cropping feature. The Output tab includes an image area 

that previews the output frame size and pixel aspect ratio (PAR). A time display and a timeline are located under the 

image area in both the Source panel and Output panel. The timeline includes a playhead, a viewing area bar, and 

buttons for setting In points and Out points. Other tabs include various encoding settings, depending on the selected 

format.

CA

D

B
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Export Settings dialog box
A. Source tab  B. Output tab  C. Source tab menu button  D. Image area  E. Export settings  F. Options tabs  

Viewing area options

These options are available on the panel menu of the Export Settings viewing area:

Aspect Ratio Corrected Preview Displays the image, correcting for differences between the source file native pixel 

aspect ratio (PAR) and your computer screen.

1:1 Pixel Preview Displays the image using a square PAR. If the source file native PAR uses non-square pixels, the 

image appears distorted on a computer screen.

Viewing area controls

• To scale the video image, choose a scale setting from the View Zoom Level menu. Fit scales the image to fit into the 

available image area. The zoom level affects only the image in the dialog box; it does not affect the source file or 

exported file. You can zoom out by pressing Ctrl+ hyphen (Windows), or Command+ hyphen (Mac OS). You can 

zoom in by pressing Ctrl+ equals (Windows), or Command+ equals (Mac OS). Do not use the numeric keypad.

• To cue the video numerically, drag the timecode display; or click the timecode display and enter a valid number.

• To cue the video using timeline controls, click or drag in the timeline under the image to set playhead.

Pre-encoding tasks

In general, it’s best to apply certain processing options—such as deinterlacing and cropping—to an exported file before 

encoding it to a particular format. Doing so can prevent visual artifacts associated with performing the same tasks after 

encoding. These tasks are pre-encoding tasks. The cropping options, deinterlacing options, and filters options you 

specify in the Export Settings dialog box are applied before encoding.

Note: You can access the Gaussian Blur filter option (a pre-encoding task) by selecting the Filters tab.

A B C

D

E

F
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Automatic deinterlacing

Adobe Media Encoder deinterlaces video before encoding whenever you choose to encode an interlaced source to a 

noninterlaced output.

Crop the source before encoding

1 In the Export Settings dialog box, select the Source tab.

2 Select the Crop button and do any of the following:

• To crop the image interactively, drag the sides or corner handles of the crop box around the source image.

• To crop numerically, enter the values for Left, Top, Right, Bottom, in pixels.

• To constrain the proportion of the cropped image, choose an option from the Crop Proportions menu.

3 Click the Output tab to preview the cropped image. 

4 From the Crop Setting menu, choose one of the following:

Scale To Fit  To eliminate letterboxing and pillarboxing resulting from cropping, or from using video of different pixel size.

Black Borders To allow letterboxing or pillarboxing if you resize the target dimensions larger than the source video.

Change Output Size  To automatically set the frame height and frame width of the output to the height and width of 

the cropped frame. Choose this setting if you want to export content for use with Flash Player or other web applications 

without black borders such as those used with letterboxing or pillarboxing.

Note: The minimum size to which you can crop an image is 40 pixels by 40 pixels.

Export Settings Format options

When you export using Adobe Media Encoder, you select a format in the Export Settings dialog box for your output. 

The format you select determines which Preset options are available. Select the format best suited for your output goal. 

Depending on the product, select from these options:

Microsoft AVI (Windows only) A video file format developed for Windows. Filename extension: .avi.

Windows Bitmap (Windows only) A still-image format developed for Windows. Filename extension: .bmp.

Note: You can export a clip, project, or sequence as a series of frames in Windows Bitmap format. With Windows Bitmap 

selected as the format, check Export As Sequence on the Video tab.

Animated GIF (Windows only) An animation format developed for web delivery. Filename extension: .gif.

GIF (Windows only) A still-image format developed for web delivery. Filename extension: .gif.

Audio Interchange File Format (Mac OS only) AIFF-C, developed for 5.1 audio channel mapping. Filename extension: .aif.

Waveform Audio File (Mac OS) or Windows Waveform (Windows) An audio file format developed for Windows, but 

supported on Mac OS. Filename extension: .wav.

P2 Movie Media eXchange Format, Op-Atom variety used by Panasonic DVCPRO50 and DVCPRO HD video 

cameras. Filename extension: .mxf.

QuickTime (available in Windows only if QuickTime is installed) The Apple Computer multimedia architecture that 

includes some codecs. The Adobe Media Encoder Export Settings dialog box is useful for setting options for 

QuickTime codecs. Filename extension: .mov.

Targa Filename extensions: .tga.

Note: You can export a clip, project, or sequence as a series of frames in Targa format. With Targa selected as the format, 

check Export As Sequence on the Video tab.
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TIFF Filename extension: .tif.

Note: You can export a clip, project, or sequence as a series of frames in TIFF format. With TIFF selected as the format, 

check Export As Sequence on the Video tab.

Uncompressed Microsoft AVI (Windows only) A video file format developed for Windows, useful for high-definition 

output. Filename extension: .avi.

MP3 An audio file format without digital rights management features, developed for web delivery. Filename 

extension: .mp3.

Audio Only Filename extension: .aac.

FLV | F4V The Adobe format for delivering audio and video over the web and other networks. Filename extensions: 

.flv, .f4v.

H.264 An MPEG-4-based standard for encoding for a variety of devices, including high-definition displays, 3GPP 

mobile phones (Windows only), video iPod, and PlayStation Portable (PSP) devices. Filename extensions: .aac (audio 

only), .3gp (Windows only), .mp4, .m4v.

H.264 Blu-ray A subset of the MPEG-4-based standard that supports encoding in high definition for Blu-ray disc 

media. Filename extension: .m4v.

MPEG4 Filename extension: .3gp.

MPEG-1 (Windows only) A set of standards defined by the Moving Picture Experts Group (MPEG) designed to deliver 

video and associated audio at bit rates around 1.5 Mbps. Generally, MPEG-1 movies are suitable for delivery formats 

such as CD-ROM and as progressively downloadable files on the web. Filename extension: .mpa (audio only), .mpg.

MPEG-2 One of a set of standards defined by the Moving Picture Experts Group (MPEG). MPEG-2 supports encoding 

of video and associated audio at bit rates up to around 10.08 Mbps. MPEG-2 can deliver high-quality, full-screen, 

full-motion video. Filename extensions: .mpa (audio only), .mpg.

MPEG2-DVD A subset of the MPEG-2 standard designed for encoding standard-definition video for DVD media. 

DVDs are a widespread distribution medium that can be played on computer DVD drives, or on set-top DVD players. 

Filename extension: .m2v.

To make an AutoPlay DVD, you can burn an MPEG2-DVD file directly onto a blank DVD. Alternatively, you can 

use an MPEG2-DVD file in an authoring program (such as Encore) to create a DVD with navigational menus and 

other features.

MPEG-2 Blu-ray A subset of the MPEG2 standard designed for encoding for high-definition Blu-ray disc media. 

Filename extensions: .m2v, .wav (audio only).

Windows Media (Windows only) A Microsoft multimedia architecture that includes various codecs, including some 

for web delivery. Filename extensions: .wma (audio only), .wmv.

Encode video and audio with Adobe Media Encoder

You can select individual files and specify different settings based on the type of video format and quality required for 

each file, or you can select multiple files and specify the same settings for all of them.

1 Start Adobe Media Encoder  by selecting Start > All Programs > Adobe Media Encoder (Windows), or open the 

folder that contains the Adobe Media Encoder application, and double click the application icon (Macintosh).

2 In Adobe Media Encoder , add source video or audio clips, Adobe Premiere Pro sequences, or Adobe After Effects 

compositions to the list of files to encode. You can drag a file into the list, or click the Add button and select a file 

on your computer.
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Note: To add Adobe Premiere Pro sequences or Adobe After Effects compositions to the list of files to encode, you must 

use the File > Add Adobe Premiere Pro sequences or File > Add Adobe After Effects Compositions menu commands. 

These file types cannot be dragged into the list of files to encode.

• To add video or audio clips, drag a file into the list, or click the Add button and select a file on your computer.

You can select multiple video files and drag them into the list of files to encode. 

• To add an Adobe Premiere Pro sequence, select File > Add Adobe Premiere Pro sequences. In the Select 

Premiere Pro Sequence dialog box, select a Premiere Pro project on your computer, and click OK.

• To add Adobe After Effects compositions, select File > Add Adobe After Effects Compositions. In the Select 

After Effects Compositions dialog box, select After Effects compositions on your computer, and click OK.

3 Click the Format menu and select a format with which to encode the video or audio clip.

4 Click the Preset menu, and select an encoding preset suitable for your intended application.

Choosing a format automatically makes available a list of associated presets designed for particular delivery 

scenarios (for example, the Apple iPod Video Small preset for the H.264 format). Choosing a preset activates the 

appropriate options in the various settings panels (Video, Audio, and so on).

5 Verify that the export profile you’ve selected is appropriate for your intended application.

6 Enter a filename for the encoded file. If you don’t specify a filename, Adobe Media Encoder  uses the filename of 

the source video clip.

You can specify a destination folder in which to save the encoded file relative to the folder containing the source 

video clip. When specifying a destination folder:

• The destination folder you specify must already exist. If you specify a folder that does not exist, an error message 

informs you that the file cannot be encoded because the folder cannot be found. 

• When specifying a folder, separate the folder name and the filename using either a forward slash (/) or backward 

slash (\) (Windows), or a forward slash (/) (Macintosh).

You can specify a folder in which to save encoded files using the Adobe Media Encoder  Preferences. 

7 Do one of the following:

• Select Edit > Export Settings to further adjust the encoding settings, embed cue points, or to modify the size or 

playback length of the video clip using the crop and trim controls.

• Click OK to close the Export Settings dialog box.

8 Click Start Queue to begin encoding your files.

Adobe Media Encoder  starts encoding the first file in the video encoding list. While a file is being encoded, the 

Status column of the video encoding list provides information on the status of each video:

Encoding  indicates that the file is currently being encoded. Adobe Media Encoder  encodes only one file at a time.

Waiting indicates that the file is in the encoding queue but has not been encoded. You can remove a file from the 

queue that has not been encoded or that is not being encoded.

Encoding Complete icon  Indicates that the specified file has been successfully encoded.

Error icon   Indicates that the user canceled the encoding process while the file was being encoded.

Warning icon   Indicates that Adobe Media Encoder  encountered an error when attempting to encode the 

specified file. Errors are recorded to a log file.
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Note: You can click the status icon to display the error log to troubleshoot any encoding errors you encounter.

If you exit and restart Adobe Media Encoder , or stop and restart the queue, a dialog box appears that lets you select 

the file to encode.

9 The encoded files are saved to the same folder as the source video files with the filename extension of the export 

format appended to the filename to identify them. If you encode the same file more than once, an incremental 

number is appended to the filename for each additional encoding.

See also 

“Remove files from the encoding queue” on page 24

“View the Adobe Media Encoder log file” on page 38

“Adobe Media Encoder application preferences” on page 31

Presets for export settings

When exporting with Adobe Media Encoder, choosing a format automatically makes available a list of associated 

presets designed for particular delivery scenarios. Selecting a preset, in turn, activates the appropriate options in the 

various settings tabs (Video, Audio, and so on). In most cases, one of the provided presets matches your output goals. 

However, you can also adjust the parameters of an existing preset and save it as a custom preset. You can share 

customized presets with others and reload them whenever needed.

Note: Adobe Technical Support supports only Adobe Media Encoder presets that are included with Adobe applications.

Create and save a custom preset

When you change any of the options that come with a preset, you can save the modified preset as a custom preset.

1 In the Format menu, select a format.

2 In the Preset menu, select the preset that most closely matches the settings you want, or select Custom.

3 To exclude video or audio from the exported file, deselect the appropriate option in the Export Settings section.

4 Select any of the available options tabs and select options as needed.

5 To include metadata, click the panel menu button in the tab area and select Include Source XMP Metadata (see 

“Exporting XMP metadata” on page 37).

6 To add or remove alternates, click the panel menu button in the tab area and select Add/Remove Alternates.

7 To crop the source video, click the Crop button in the Source tab. Then, crop the image (see “Pre-encoding tasks” 

on page 19).

Note: Altering any setting changes the preset name to “Custom,” until you save the settings as a new preset.

8 When you’re finished customizing a preset, click the Save Preset button .

9 Type a name for the preset.

10 Do any of the following, and then click OK:

• To include filter settings you specified in the Filters tab in the preset, check Save Filter Settings.

• To include options you specified in the Others tab (such as FTP settings), check Save Other Tasks.

Presets are stored in the following location:

• Windows XP: C:\Documents and Settings\user\Application Data\Adobe\Adobe Media Encoder\4.0\Presets

• Windows Vista: C:\Users\user\AppData\Roaming\Adobe\Adobe Media Encoder\4.0\Presets
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• Macintosh: Macintosh HD/Users/user/Library/Application Support/Adobe/Adobe Media Encoder/4.0/Presets

Import a preset

In the Export Settings dialog box, you can add presets by importing preset files.

1 Click the Import Preset button .

2 Navigate to the location of the preset, select it, and then click Open.

3 Type a name for the imported preset, specify other options, and then click OK.

Export a preset

1 In the Export Settings dialog box, choose the preset you want to export.

2 Alt-click (Windows) or Option-click (Mac OS) the Save Preset button .

3 Choose the location to save the preset, name it, and then click Save. 

The preset is saved as an EPR file.

Delete custom presets

1 In the Export Settings dialog box, choose the custom preset you want to delete.

2 Do either of the following: 

• To delete a single preset, click the Delete Preset button .

• To delete all custom presets, Ctrl+Alt-click (Windows) or Command+Option-click (Mac OS) the Delete Preset 

button.

3 Click Yes to confirm the deletion.

Manage file encoding

Save the encoding queue

You can manually save the current encoding queue—including all encoding settings. If you do not choose to save the 

encoding queue, it is saved automatically when you exit Adobe Media Encoder .

• Select File > Save Queue.

Remove files from the encoding queue

You can remove any video from the encoding queue before it is encoded. 

1 Select the video (or videos) that you want to remove from the source file list.

2 Click Remove.

A dialog box prompts you to confirm that you want the selected files removed from the encoding queue.

Skip a file

You can specify that Adobe Media Encoder  not encode a file in the current encoding queue. 

Skip a file
1 Select the file or files that you want to skip in the encoding queue. To select multiple files in the encoding queue, 

Control-click (Windows) or Command-click (Macintosh).
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2 Select Edit > Skip Selection.

Reset a skipped file for encoding
1 Select the file or files in the encoding queue that you want to reset to the Waiting to Encode state. To select multiple 

files in the encoding queue, Control-click (Windows) or Command-click (Macintosh).

2 Select Edit > Reset Status.

The selected file or files are reset to the Waiting to Encode state. You can reset the status of files while 

Adobe Media Encoder  is encoding.

Stop encoding the current file

You can stop the encoding process for any file that is currently being encoded. If you don’t want to encode a file that 

is waiting to be encoded, you can either remove that file from the encoding queue, or specify that the file be skipped.

• Select File > Stop Current File.

A dialog box prompts you to confirm that you want to stop the current file from encoding. Click OK to stop the 

encoding process. An error message that states “The operation was interrupted by the user” is written to the log file.

See also 

“View the Adobe Media Encoder log file” on page 38

Create a watch folder

You can configure Adobe Media Encoder  to look for video or audio files in certain folders called watched folders. 

When Adobe Media Encoder  finds a video or audio file located in a watched folder, it encodes the file using the 

encoding settings assigned to the folder, and then exports the encoded file to an Output folder created inside the 

watched folder. 

1 Select File > Create Watch Folder.

2 Select the target folder. You can select a watched folder at any level of a hard drive.

3 Click OK. The folder you select becomes a watched folder, and is added to the top of the encoding queue.

4 Click the Format menu and select a format with which to encode the video or audio clips in the watched folder.

5 Click the Preset menu, and select an encoding preset suitable for your intended application. All video or audio clips 

in the watched folder are exported using the preset you select.

6 Click Start Queue to begin encoding your files. Adobe Media Encoder  populates the list of files to encode with all 

of the audio and video files found in the watched folder. 

Adobe Media Encoder  automatically creates an Output folder in the watched folder into which it exports the 

encoded files. 

Remove a watched folder from the encoding queue

You can remove any watched folder from the encoding queue when its contents are not being encoded. 

1 Select the folder (or folders) that you want to remove from the source file list.

2 Click Remove.

A dialog box prompts you to confirm that you want the selected folders removed from the encoding queue.
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Cue points for FLV and F4V video files

Cue points cause the playback of video to start other actions within the presentation and let you synchronize the video 

with animation, text, graphics, and other interactive content. For example, you can create a Flash presentation that has 

video playing in one area of the screen while text and graphics appear in another area. 

Each cue point consists of a name, the time at which it occurs in the video, type of cue point, and optional parameters. 

You specify cue point times using the format hour:minute:second:millisecond. When the encoded video file is played 

back within a Flash SWF file, and the video plays or seeks to the elapsed time specified by the cue point, the action 

you’ve specified is triggered.

Adobe Media Encoder  lets you embed cue points in video clips using the Export Settings dialog box. You can assign 

each cue point an event type and parameter that can be used with ActionScript™ or the Flash FLVPlayback component 

to programmatically cause the video playback to start other actions in the presentation. 

Note: In addition to embedding cue points within the encoded FLV video clip, you can create cue points using the 

FLVPlayback component. Using this component, you can create a cue point that is not embedded in the video clip itself, 

providing greater flexibility in triggering events. For more information, see the information on the FLVPlayback 

component in the ActionScript 2.0 Components Language Reference or the ActionScript 3.0 Components Language 

Reference.

Note that cue point metadata is stored differently in F4V and FLV file types. Refer to “Using cue points and metadata” 

in Programming ActionScript 3.0 for information on the differences between cue points in F4V and FLV files, and how 

to use them in Flash.

To synchronize an action for a cue point in an F4V video file, you must retrieve the cue point data from the 

onXMPData() callback functions and trigger the cue point using the Timer class in ActionScript 3.0. The onXMPData() 

callback function receives information specific to Adobe Extensible Metadata Platform (XMP) that is embedded in the 

Adobe F4V video file. The XMP metadata includes cue points as well as other video metadata. XMP metadata is 

introduced with Flash Player 10 and supported by subsequent versions of Flash Player and Adobe AIR. For more 

information on onXMPData()and F4V cue points see “Using onXMPData()” in Programming ActionScript 3.0.

Creating cue points from Adobe Premiere Pro and Adobe After Effects markers 

Composition markers (After Effects) and sequence markers (Adobe Premiere Pro) can be converted into Flash cue 

points. When creating markers in Premiere Pro or After Effects, you can enter the Flash cue point name, names and 

values for any parameters, and select the type of cue point to create (for example, an Event or Navigation cue point). 

For more information on creating Adobe Flash cue points from composition markers or sequence markers, see After 

Effects Help or Adobe Premiere Pro Help.

About the cue point XML file

The cue point XML file lets you save your cue point data, and apply it to other video clips. The XML format lets you 

share it across platforms and applying it to any video that supports the F4V or FLV cue point format. An example of 

the file is shown below:
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 <?xml version="1.0" encoding="UTF-8"?>  
 <FLVCoreCuePoints>  
 <CuePoint>  
 <Time>2000</Time>  
 <Type>navigation</Type>  
 <Name>CuePoint1</Name>  
 <Parameters>  
 <Parameter>  
 <Name>CuePoint1</Name>  
 <Value>Introduction</Value>  
 </Parameter>  
 <Parameter>  
 <Name>Cast</Name>  
 <Value>ActorNames</Value>  
 </Parameter>  
 </Parameters>  
 </CuePoint>

Important: If you modify the cue point XML file and insert invalid values or otherwise malformed XML syntax, 

Adobe Media Encoder  will not be able to load the file.

The DTD (Document Type Definition) for the cue point XML file is shown below (A DTD defines the valid document 

structure of the XML file, with a list of supported elements and their meaning within the XML file itself):

 <!DOCTYPE FLVCoreCuePoints [  
 <!ELEMENT FLVCoreCuePoints(CuePoint+)>  
 <!-- FLVCoreCuePoints is the root element in the XML file and must contain at least one CuePoint 
element -->  
 <!ELEMENT CuePoint(Time, Type, Name, Parameters?)>  
 <!-- CuePoint contains the data for a particular cue point, and must contain one each of  
 Time, Type, and Name elements, and may contain one Parameters element -->  
 <!ELEMENT Time(#CDATA)>  
 <!-- Time contains the cue point time as an integer in milliseconds -->  
 <!ELEMENT Type(#CDATA)>  
 <!-- Type contains the cue point type as a case-sensitive string, either "event" or "navigation" 
-->  
 <!ELEMENT Name(#CDATA)>  
 <!-- Name contains the cue point name as a text string; it also can contain a parameter name 
when appearing  
 inside a Parameter element -->  
 <!ELEMENT Parameters(Parameter+)>  
 <!-- Parameters contains the cue point's parameters. It must contain at least one Parameter 
element -->  
 <!ELEMENT Parameter(Name, Value)>  
 <!-- Parameter contains the data for one of a cue point's parameters. It must contain one each of  
 Name and Value elements -->  
 <!ELEMENT Value(#CDATA)>  
 <!-- Value contains the value-part of the name-value pair for a cue point parameter -->  
 ]>

In addition to the restrictions enforced by the cue point XML DTD, the following characteristics apply to the XML 

format:

• All comments regarding the data inside the tags in the DTD will be enforced on read; non-compliant XML will 

result in an error.

• Cue points must appear in ascending time order within the XML file, and there can be only one cue point assigned 

at a given time.
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• The XML format is written as UTF-8. Other encoding types are supported if they are properly declared via an XML 

declaration with encoding (for example, <?xml version="1.0" encoding="UTF-16"?> or a BOM marker in the file.

• The only types allowed are “event” and “navigation,” both of which must be written using lowercase letters.

• Time must be specified in milliseconds as an integer. You cannot use decimal points when specifying time (for 

example, 12.123 causes the XML file to fail). 

• Cue point files that do not successfully load generate an error message.

Adobe Soundbooth and the cue point XML file

Adobe Soundbooth™, a sound editing application, can import and export the cue point XML file. An advantage to 

creating the cue point XML file in Soundbooth, is that its Video panel lets you play back video footage while editing 

sound. This lets you insert cue point markers using both the video and audio components of the file. When you are 

ready to encode the video using Adobe Media Encoder , you can import the cue point file from Soundbooth and use 

the cue points to encode the FLV file. To learn more about using Soundbooth to create cue points, and importing the 

cue points XML file into Adobe Media Encoder , see the information on working with Flash and video in Using 

Soundbooth.

Define and embed cue points for Adobe F4V and FLV files

Cue points cause the video playback to start other actions within the presentation. For example, you can create a Flash 

presentation that has video playing in one area of the screen while text and graphics appear in another area. A cue point 

placed in the video starts an update to the text and graphic, while they remain relevant to the content of the video.

Each cue point consists of a name and the time at which it occurs. You specify cue point times using the format 

hour:minute:second:millisecond.

Create a cue point

1 From the encoding queue, select a video in which you want to embed cue points.

To select a video in the encoding list, click the video name in the video encoding queue.

2 If you haven’t specified encoding settings for the video clip, do so now. Verify that the video use the FLV or FV4 

encoding format. You can only embed cue points in FLV or F4V video files. To learn more, see “Encode video and 

audio with Adobe Media Encoder” on page 21.

3 Select Edit > Export Settings.

The Export Settings dialog box is displayed.

4 The cue point controls are located in the lower left corner of the Export Settings dialog box.

Cue point controls.
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5 Use the playhead to locate a specific point in the video where you want to embed a cue point. For greater precision, 

you can use the Left and Right Arrow keys to move the playhead in millisecond increments. To do this, select the 

playhead, and then use the arrow keys to further adjust its position.

To locate a specific time, drag the playhead to the point in the video where you want to embed a cue point. The 

video preview window lets you visually identify points in the video at which to insert a cue point. You can also use 

the elapsed time counter (located beneath the video preview window) to locate specific points in time at which to 

embed cue points.

6 When the playhead is positioned at a place in the video where you want to embed a cue point, click the (+) button 

on the right side of the cue point controls.

Adobe Media Encoder  embeds a cue point at the time indicated by the counter beneath the video preview window, 

and populates the cue point list with a placeholder for the name of the new cue point and the elapsed time at which 

the cue point is located (this is the time during playback when the event will be triggered), and displays a pop-up 

menu that lets you select the type of cue point to embed.

Note: Only one cue point can be embedded at a specified time code within the video clip.

7 Specify the type of cue point you want to embed. You can embed either a navigation or event cue point.

• Event cue points are used to trigger ActionScript methods when the cue point is reached, and let you 

synchronize the video playback to other events within the Flash presentation.

• Navigation cue points are used for navigation and seeking, and to trigger ActionScript methods when the cue 

point is reached. Embedding a navigation cue point inserts a keyframe at that point in the video clip to enable 

viewers to seek to that place in the video.

Note: Adding additional key frames can lower the overall quality of a video clip. For this reason, only use 

navigation cue points when users need to seek to a particular place within the video. 

8 Enter parameters for the selected cue point. 

Parameters are a set of key-value pairs that you can add to the cue point. The parameters are passed to the cue point 

event handler as members of the single parameter object.

To learn more about using cue points, and the parameter values they can use, see the following:

• Information on working with video in Using Flash

• FLVPlayback information in the ActionScript 2.0 Components Language Reference or the ActionScript 3.0 

Components Language Reference

9 (Optional) Save the cue points you’ve created so that you can apply them to other video clips. Click the Save Cue 

Points button (the disk icon) on the cue points tab, and save the file to a location on your computer.

See also 

“Key frames” on page 6

Remove a cue point

1 Select the cue point in the cue point list.

2 Click the Delete Cue Point button (-), or press the Delete key.

The cue point is deleted from the cue point list.

Load previously saved cue point data

1 Click the Load Cue Points button  on the cue points tab.
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2 Select the cue point file you want to import, and click OK.

The cue point file loads, and populates the cue point list with the cue points specified in the file. 

Note: When you load cue points from a file, any cue points you have created in the cue points list are replaced by the 

cue points in the file.

Crop, trim, and resize video

Adobe Media Encoder  provides the following editing options that let you crop and trim video clips before encoding 

them: 

Cropping lets you alter the dimensions of a video clip. You can eliminate areas of the video to emphasize a particular 

focal point within the frame, such as highlighting a character by removing ancillary imagery or removing unwanted 

backdrops.

Trimming lets you edit the beginning and ending points (the in and outpoints) of a video. For example, you can adjust 

the trim of a video clip to begin playback 30 seconds into the full clip, removing unwanted frames.

Resizing lets you modify the width and height of the video frame. You can specify a frame size in pixels or as a 

percentage of the original image size.

1 Select a video you want to crop, trim, or resize.

To select a video in the encoding list, click the video name in the video encoding queue.

2 Select Edit > Export Settings.

The Export Settings dialog box is displayed.

3 If you haven’t yet specified encoding setting for the video clip, do so now. To learn more, see “Encode video and 

audio with Adobe Media Encoder” on page 21.

4 The crop and resizing controls are located in the upper left corner of the Export Settings dialog box, above the video 

preview.

5 Enter values for the right, left, top, and bottom edges to crop the video, or use the Crop tool button  to visually 

adjust the dimensions of the video. Guides in the preview window indicate the cropped area. 

6 Click the Crop Proportions pop-up menu, and select an aspect ratio for the crop rectangle. 

7 Click the Output tab to preview the cropped image. From the Crop Setting menu, choose one of the following:

• Scale To Fit To eliminate letterboxing and pillarboxing resulting from cropping, or from using video of different 

pixel size.

• Black Borders To allow letterboxing or pillarboxing if you resize the target dimensions larger than the source 

video.

• Change Output Size To automatically set the frame height and frame width of the output to the height and 

width of the cropped frame. Choose this setting if you want to export content for use with Flash Player or other web 

applications without black borders such as those used with letterboxing or pillarboxing.

Note: The minimum size to which you can crop an image is 40 pixels by 40 pixels.

8 To set the in and out points (the points at which the video begins and ends), drag the in and out point markers 

below the scrubber bar until you finish adjusting the video clip size. 

The video preview window lets you visually identify beginning and ending frames where you can trim the video 

clip. You can also use the elapsed time counter (located in the Trim section of the dialog box) to locate specific 

points in time where you can trim the video clip. 
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9 Preview the video by dragging the playhead over the scrubber bar to ensure that it plays appropriately. 

10 When you finish cropping and trimming the video, you can add cue points, further modify the export settings of 

the video, or click OK to return to the main Adobe Media Encoder  dialog box.

If you are ready to encode your video clips, or want to add additional source video clips to encode, see “Encode 

video and audio with Adobe Media Encoder” on page 21.

Note: When you encode the video, the original source video clip is not changed. You can always re-encode a video clip 

and specify new settings if your initial attempt does not produce the results you want.

Adobe Media Encoder application preferences

Adobe Media Encoder  lets you set preferences for general application operations, editing operations, and clipboard 

operations.

1 Select Edit > Preferences (Windows) or Adobe Media Encoder > Preferences (Macintosh).

2 Select your preferences from the following options:

Increment output filename if file with same name exists By default, Adobe Media Encoder  increments each file 

you encode with the same name by appending a number to the filename. For example, if you encode a video clip 

and create the output file video.flv, and then decide to re-encode the same file without deleting video.flv, 

Adobe Media Encoder  names the next file video_1.flv. To disable filename incrementing, deselect the Increment 

Output Filename If File With Same Name Exists option.

Important: If you choose to disable filename incrementing, Adobe Media Encoder  writes over any existing files in the 

destination folder with the same name. To prevent the over writing of files, name your video clips in such a way that 

they don’t inadvertently overwrite one another.

Remove completed files from queue on exit Specifies that files be removed from the encoding queue once they’ve 

been encoded. This removes any encoded files from the encoding queue when you exit (close).

Warn on stop queue or remove file By default, Adobe Media Encoder  prompts you with a warning if you attempt 

to stop encoding a queue, or remove a file during the encoding process. To disable the warning deselect this item.

Delayed Start Specifies that batch encoding begins after a time delay that you specify. When you click Start Queue 

after having selected the Delayed Start option, a dialog box prompts you to enter a start time for batch encoding 

queues. 

Preview while encoding Specifies that the currently encoding video be shown in the Adobe Media Encoder Batch 

Window.

Place output files in Specifies a folder in which to place encoded media files. By default, Adobe Media Encoder  

places exported files in the same folder as the source video clip, prepending the export format’s filename extension 

to differentiate the newly encoded video clip from its source video. To select a different destination folder in which 

to place encoded media clips, select the Place Output Files In option, and click the Browse button to Select an 

existing folder on your local computer, or create a folder in which to output encoded video files. 

Language Specifies the language to use with Adobe Media Encoder .

Display Format Lets you specify a Display Format timecode that appears in the Preview tab of the Export Settings 

dialog box.

User Interface Brightness Lets you brighten or dim the Adobe Media Encoder  interface so that your video preview 

stands out on screen.

Write XMP ID to File on Import Specifies the GUID tagging of files during import.
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Save Media Cache file next to originals when possible Saves media cache files in the same folder as the original 

files.

Custom encoding settings

Customize encoding settings

The Export Settings dialog box (Edit > Export Settings) of Adobe Media Encoder  let you create custom video and 

audio encoding settings.

Before creating custom video encoding settings, be sure that you understand the different video encoding options. For 

information about video encoding options, see “About video and audio encoding” on page 5.

1 Select the file or files whose encoding settings you want to modify. 

To select multiple files in the encoding list, Control-click (Windows) or Command-click (Macintosh), or select Edit 

> Select All to select all files in the encoding queue.

2 Select Edit > Export Settings.

The Export Settings dialog box appears. This dialog box lets you perform the following actions:

• Specify alternate encoding settings to deliver video for different bandwidths and applications.

• Create cue points to trigger events.

• Crop and resize the video clip to alter its dimensions.

• Trim the length of the video to change its beginning and ending frames.

See also 

“Define and embed cue points for Adobe F4V and FLV files” on page 28

“Crop, trim, and resize video” on page 30

Filters export settings

Gaussian Blur
The Gaussian Blur effect softens the image and eliminates noise. Adobe Media Encoder applies the Gaussian Blur 

effect as a pre-encoding task. This step minimizes the noise that the encoder would otherwise have to encode. It results 

in quicker encoding, smaller output file sizes, better image quality, and often an improvement in the display of motion. 

You can specify the direction of the blur. Select the Output tab to preview the results of this effect.

Blurriness Controls the amount of blur. Higher numbers cause more blur. Drag the hot text, or type a number, to 

specify the amount of blur.

Blur Dimension Controls the direction of the blur. Select either Horizontal And Vertical, Horizontal, or Vertical from 

the menu.

Note: You can remove noise and grain from a project for reasons other than improved encoding and reduction of 

compressed file size. Consider the Noise & Grain effects, or blur effects, in Adobe Premiere Pro and After Effects.



33USING ADOBE MEDIA ENCODER CS4 

Encoding media

Video export settings

In the Export Settings dialog box, the options available on the Video tab depend on the format you’ve specified. Video 

settings include one or more of the following options. Video settings are listed under headings such as Video Codec, 

Basic Video Settings, Advanced Settings, Bitrate Settings, Video Hinter Track Settings, and GOP Settings.

Note: Some capture card and plug-in software applications provide their own dialog boxes with specific options. If the 

options you see are different from the options described here, see the documentation for your capture card or plug-in.

To save final rendering time:

• Use the same codec to capture and export.

• Render previews of your sequences as you make changes.

• Set the export quality setting to match the capture quality setting.

Video Codec or Codec Specifies the codec used to encode the video. The codecs available depend on the format you 

choose.

Note: If you cannot find options that your hardware-based codec provides, see the documentation provided by the 

hardware manufacturer. Some codecs included with video-capture hardware require that you set compression options in 

their own dialog boxes.

Quality Specifies video quality. Generally, higher values increase rendering time and file size. If available, drag the 

slider or type a value to affect the exported picture quality. Increasing quality above the original capture quality does 

not increase quality, but may result in longer rendering times.

Width or Frame Width Specifies the width of the frame of the output file in pixels.

Height or Frame Height Specifies the height of the frame of the output file in pixels.

Frame Rate Specifies the frame rate of the output file in frames per second. Some codecs support a specific set of frame 

rates. Increasing the frame rate may produce smoother motion (depending on the frame rate of the source clip, project, 

or sequence) but uses more disk space.

Depth Specifies the color depth in bits per channel (bpc): the number of bits allocated per color channel. Options are 

8 Bit, 16 Bit, 24 Bit, or 32 Bit.

Encode Alpha Channel Enables encoding of an alpha channel into the exported file for formats, such as FLV, that 

support alpha channels.

TV Standard Conforms the output to the NTSC standard or PAL standard.

Field Order Specifies whether the output file will have progressive frames or interlaced fields, and if the latter, which 

field will be written first. Progressive is the correct setting for computer display and motion picture film. Choose Upper 

First or Lower First when exporting video for an interlaced medium, such as NTSC, or PAL.

Aspect or Pixel Aspect Ratio Specifies pixel aspect ratio. Select one appropriate for the output type. When the pixel 

aspect ratio (displayed in parentheses) is 1.0, the output will have square pixels; all others will have rectangular pixels. 

Because computers generally display pixels as squares, content using non-square pixel aspect ratios appear stretched 

when viewed on a computer but appear with the correct proportions when viewed on a video monitor.

Bitrate Mode or Bitrate Encoding Specifies whether the codec achieves a constant bitrate (CBR) or variable bitrate 

(VBR) in the exported file: 

• Constant Compresses each frame in the source video to the fixed limit you specify, producing a file with a fixed 

data rate. Therefore, frames containing more complex data are compressed more, while less complex frames are 

compressed less. 
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• Variable Constrained Allows the exported file’s data rate to vary within a range you specify. Because a given 

amount of compression degrades the quality of a complex image more than it degrades the quality of a simple image, 

VBR encoding compresses complex frames less and compresses simple frames more.

• Variable Unconstrained Allows the exported file’s data rate to vary without limit.

• CBR Constant bitrate

• VBR, 1 Pass Variable bitrate, with the encoder making a single pass through the file from beginning to end. Single-

pass encoding takes less time than dual-pass encoding, but doesn’t achieve the same quality in the output.

• VBR, 2 Pass Variable bitrate, with the encoder making two passes through the file, from beginning to end, and then 

from end to beginning. The second pass prolongs the process, but it ensures greater encoding efficiency, and often a 

higher quality output.

Note: When comparing CBR and VBR files of the same content and file size, you can make the following generalizations: 

A CBR file may play back more reliably over a wider range of systems, because a fixed data rate is less demanding on a 

media player and computer processor. However, a VBR file tends to have a higher image quality, because VBR tailors the 

amount of compression to the image content.

Bitrate Specifies the number of megabits per second of playback for the encoded file. (This setting is available only if 

you select CBR as the Bitrate Encoding option.)

The following options appear only if you select VBR as the Bitrate Encoding option:

Encoding Passes Specifies the number of times the encoder will analyze the clip before encoding. Multiple passes 

increase the time it takes to encode the file, but generally result in more efficient compression and higher image quality. 

(Adobe After Effects doesn’t support multiple encoding passes.)

Set Bitrate Available only for the QuickTime format. Select to keep the bitrate of the output file constant.

Bitrate [kbps] Available only for the QuickTime format. Select if you want to determine the bitrate. Then, drag the 

slider until the hot text displays the desired value.

Maximum Bitrate [Kbps] Specifies the maximum bitrate you want the encoder to allow.

Average Video Bitrate [Kbps] Specifies the average video bitrate you want the encoder to allow.

Target Bitrate [Mbps] Specifies the average video bitrate you want the encoder to allow when encoding video using the 

H.264 video codec.

Peak Video Bitrate [Kbps] Specifies the top bitrate you want the encoder to allow.

Minimum Bitrate Specifies the minimum number of megabits per second of playback you want the encoder to allow. 

The minimum bitrate differs according to the format. For MPEG-2-DVD, the minimum bitrate must be at least 

1.5 Mbps. 

Allow Interlaced Processing Select this option if the video content in the sequence is interlaced and you are exporting 

to a noninterlaced medium, such as motion picture film or progressive scan video. Deinterlacing can also make it 

easier to apply high-quality effects in another program, such as After Effects. If the sequence content does not have 

fields, don’t select this option; instead select No Fields from the Fields option.

M Frames Specifies the number of B frames (Bi-directional frames) between consecutive I frames (Intra-frames) and 

P frames (Predicted frames).

N Frames Specifies the number of frames between I frames (Intra-frames). This value must be a multiple of the M 

frames value.

Optimize Stills or Expand Stills Select this option to use still images efficiently in exported video files. For example, if 

a still image has a duration of 2 seconds in a project set to 30 fps, Adobe Premiere Pro creates one 2-second frame 

instead of 60 frames at 1/30 of a second each. Selecting this option can save disk space for sequences and clips 
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containing still images. Deselect this option only if the exported video file exhibits playback problems when displaying 

the still images.

Keyframe Interval [Seconds] or Key Frame Distance (Frames) Select and type the number of frames after which the 

codec will create a keyframe when exporting video. 

Simple Profile Available only when exporting in the FLV video format using the On2VP6 codec, selecting Simple 

Profile optimizes high-resolution video content that will be played back on older computers or other devices with 

limited memory and processing resources.

Undershoot [% target] Available only when exporting in the FLV video format using the On2VP6 codec, this option 

lets you specify the percentage of the target data rate to shoot for so that additional data is available in the buffer to 

improve difficult sections.

Quality Available only when exporting in the FLV format, this option lets you specify a balance between encoding 

quality and the time it takes Adobe Media Encoder  to encode video. 

• Good Strikes a balance between image quality and the amount of time it takes to encode video. This is the default 

value.

• Best Creates the best possible image quality, but will take substantially longer to encode video.

• Speed Specifies that the video be encoded as fast as possible, however, the image will be of lower quality. 

Recommended for video content used in testing deployments.

Closed GOP Every Specifies the frequency of each Closed Group of Pictures (Closed GOP), which cannot reference 

frames outside of the closed GOP. A GOP consists of a sequence of I, B, and P frames. (This option is available if you 

choose MPEG-1 or MPEG-2 as the format.)

Automatic GOP Placement When selected, sets the placement of Group of Pictures (GOP) automatically. (This option 

is available if you choose MPEG-1 as the format.)

Note: MPEG-1 and MPEG-2 formats include numerous advanced options not listed here. In most cases, selecting a 

format or preset designed for your target output sets the appropriate options automatically. For detailed information on 

options not listed, consult the specifications for the MPEG-1 (ISO/IEC 11172) and MPEG-2 (ISO/IEC 13818) formats.

Audio export settings 

In the Export Settings dialog box, the options available in the Audio tab depend on the format you’ve specified. One 

or more of these options appear on the Audio tab:

Audio Codec or Codec Specifies the codec used to encode the audio data. These options are some of the most 

commonly used codecs available through Adobe Media Encoder:

• AAC (Advanced Audio Coding) A high-quality encoding format supported by many mobile devices. This codec is 

the default for the H.264 format.

• AAC+ Version 1 Uses spectral band replication (SBR) to enhance the compression efficiency in the frequency 

domain. 

SBR is a technology that enhances audio codecs, especially at low bit rates and is based on harmonic redundancy in the 

frequency domain. The audio codec itself transmits the lower and mid-frequencies of the spectrum, while SBR 

replicates higher frequency content by transposing up harmonics from the lower and mid-frequencies at the decoder.

• AAC+ Version 2 This version of the AAC codec couples SBR with Parametric Stereo (PS) to enhance the 

compression efficiency of stereo signals. 

The AAC+ Version 2 bit stream is created by down-mixing the stereo audio signal to mono along with Parametric 

Stereo information used to describe the spatial intensity stereo generation and ambience regeneration at the decoder. 
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By having the Parametric Stereo information coupled with the mono audio stream, the decoder can regenerate a 

faithful spatial approximation of the original stereo panorama using very low bitrates.

• MainConcept MPEG Audio A high-quality encoding format developed by MainConcept, and included with Adobe 

Premiere Pro, After Effects, and Soundbooth.

• PCM (pulse-code modulation) Audio An uncompressed encoding format. Files of this format tend to be larger than 

files of the other formats.

Audio Format The file format used for storing encoded audio data. Some audio formats support only uncompressed 

audio, which has the highest quality, but uses more disk space. Some formats allow only one codec. Others allow you 

to choose from a list of supported codecs.

Sample Rate or Frequency Choose a higher rate to increase the frequency at which audio is converted into discrete 

digital values, or sampled. Higher sample rates increase audio quality and file size; lower sample rates decrease quality 

and file size. However, setting the sample rate in the Export Settings dialog box higher than the sample rate of the audio 

source doesn’t increase quality. Setting a sample rate different from the sample rate of the source file, requires 

resampling, and additional processing time. You can avoid resampling by capturing audio at the same rate at which 

you want to export it.

Channels or Output Channels Specify how many audio channels are in the exported file. If you choose fewer channels 

than are in the master track of a sequence or project, Adobe Media Encoder downmixes the audio.

Sample Type Choose a higher bit depth to increase accuracy of audio samples. Higher bit depth can improve dynamic 

range and reduce distortion, especially if you add additional processing, such as filtering or resampling. Higher bit 

depths also increase processing time and file size; lower bit rates reduce processing time and file size. However, setting 

the bit depth in the Export Settings dialog box higher than the bit depth of the source audio doesn’t increase quality.

Audio Interleave Specify how often audio information is inserted among the video frames in the exported file. See 

your capture card documentation for the recommended setting. A value of one frame means that when a frame is 

played back, the audio for the duration of that frame is loaded into RAM so that it can play until the next frame appears. 

If the audio breaks up when playing, adjust the interleave value. Increasing the value lets the computer store longer 

audio segments, and process them less often. However, higher interleave values require more RAM. Lowering the 

value can make playback smoother. Most hard disks operate best with a 1/2-second to 1-second interleave value.

Setting the value to 0 disables Audio Interleave and speeds rendering time. Consider disabling Audio Interleave for 

projects containing assets with large pixel dimensions.

Bitrate [kbps] Specifies the output bit rate of the audio. Generally, higher bit rates increase both quality and file size. 

This option is available for AAC, mp3, and FLV.

Note: Options not documented here are specific to the selected format. For detailed information, consult the specifications 

for the selected format.

Audiences export settings

In the Export Settings dialog box, selecting Windows Media (Windows only) as the format exposes the Audiences tab. 

The options on the Audiences tab allow you to output variations of a movie suited to different network speeds. The 

player software associated with the format detects and selects the most appropriate version to ensure smooth playback. 

Windows Media generates a single movie that contains variations for different connection speeds.

Note: Some codec-specific settings are not documented here. For more detailed information regarding a particular codec, 

check the documentation provided by its developer.

Compressed Specifies that the codec you select in the Video tab is applied. Compressed is the default setting, and is 

appropriate for most users.
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Uncompressed Specifies that no compression is applied. Because this setting results in large files, it is not appropriate 

for most users.

Others export settings

The Others tab of the Export Settings dialog box allows you to upload the exported file to a File Transfer Protocol 

(FTP) server that has storage space allocated for file sharing. FTP is a common method for transferring files over a 

network and is especially useful for sharing relatively large files using an Internet connection. The server’s 

administrator can provide you with the details for connecting to the server. 

The Others tab includes the following options:

Server Name Enter the DNS or IP address of the server on which the FTP site is located.

Port Specify the number assigned to the FTP server’s command port, which is 21 by default.

Remote Directory Enter the location on the FTP server to access, expressed as a file path.

User Login Enter the user’s identity, as designated by the server’s administrator.

Password Enter the password to a password-protected server.

Retries Specify the number of attempts to contact the server if a connection isn’t established.

Send Local File To Recycle Bin (Windows) or Send Local File To Trash (Mac OS) Deletes the local copy of the exported 

file once it’s been uploaded to the FTP server.

Test Verifies the connection with the FTP server.

Exporting XMP metadata

Export XMP metadata with a clip
If a clip contains metadata, you can export the clip metadata when you encode the clip.

Note: The Include Source XMP Metadata option is available when exporting MPEG-1 (Windows only), Windows Media 

(Windows only), MPEG-2, MPEG-2 Blu-ray, FLV | F4V, H.264, or QuickTime formats.

Export Settings options panel menu

1 In the Export Settings dialog box, click the Advanced Mode button , if necessary, to expose the options panels.

2 Click the panel menu button  to the right of the options panels to open the panel menu.

3 Select Include Source XMP Metadata.

Edit XMP metadata in a file before exporting
You can add metadata to a sequence or composition that can be exported when the sequence or composition is 

encoded.

1 In the Export Settings dialog box, click the Advanced Mode button , if the options panels are not already 

exposed.

2 Click the panel menu button  to the right of the options panels to open the panel menu.
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3 Select File Info.

4 In the dialog box, type information into any of the metadata fields as needed, and click OK.

Append XMP metadata to a file before exporting
1 In the Export Settings dialog box, click the Advanced Mode button , if the options panels are not already 

exposed.

2 Click the panel menu button  to the right of the options panels to open the panel menu.

3 Select File Info.

4 In the File Info window, select the tab for the type of metadata you want to import.

5 (Optional) some tabs, such as the Description tab, contain a menu offering a selection of template metadata, such 

as various types of copyright data. Select the desired type.

6  Select Import from the menu next to the OK button, and, in the Import Options pop-up menu, select the desired 

option, and click OK.

7 Browse to the desired XMP file, select it, and click Open.

8 Click OK.

Troubleshooting

View the Adobe Media Encoder log file

Adobe Media Encoder  provides a log file that lets you view the status of files that you have encoded. The log file is a 

plain text file that contains a record of all files encoded, whether successfully completed or not. The encoding status of 

each file you encode is appended to the end of the file (placing the newest entry at the end of the file). The log file adds 

entries until you manually clear them. To clear log file entries, open the file in a text editor, select all of the entries, 

delete them, and save the empty file using the default filename (AMEEncodingLog.txt).

The log file is stored in the following location:

• Windows XP: C:\Documents and Settings\user\Application Data\Adobe\Adobe Media 

Encoder\4.0\AMEEncodingLog.txt

• Windows Vista: C:\Users\user\AppData\Roaming\Adobe\Adobe Media Encoder\4.0\AMEEncodingLog.txt

• Macintosh: Macintosh HD/Users/user/Library/Application Support/Adobe/Adobe Media 

Encoder/4.0/AMEEncodingLog.txt

To view the log file:

• Select File > Show Log.

The log file is displayed using the default text editing application of the operating system. 

View encoding error messages

Adobe Media Encoder  provides an error log file that you can use to troubleshoot errors encountered when encoding 

video clips. 
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The error log file is stored in the following location:

• Windows XP: C:\Documents and Settings\user\Application Data\Adobe\Adobe Media 

Encoder\4.0\AMEEncodingErrorLog.txt

• Windows Vista: C:\Users\user\AppData\Roaming\Adobe\Adobe Media Encoder\4.0\AMEEncodingErrorLog.txt

• Macintosh: Macintosh HD/Users/user/Library/Application Support/Adobe/Adobe Media 

Encoder/4.0/AMEEncodingErrorLog.txt

To view the error log file:

• Select File > Show Errors.

The error log file is displayed using the default text editing application of the operating system. 
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